CVE-2026-9132
What it is
A missing authorization vulnerability was identified in GitHub Enterprise Server that allowed an authenticated user to read source code from private repositories they did not have access to. The Copilot pull request description diff summary endpoint accepted a cross-repository comparison range and rendered the resulting diff without verifying that the requesting user was authorized to view the target repository. Exploitation required an authenticated account on the instance with read access to at least one repository to use as the comparison base. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.17.17, 3.18.11, 3.19.8, and 3.20.4. This vulnerability was reported via the GitHub Bug Bounty program.
At a glance
- Exploitability
- Can be exploited over the network with a low-privilege account. High risk of data exposure.
- Exploit odds
- 0.4% chance of exploitation in the next 30 days (EPSS).
- Fix
- A patch, advisory or fixed version is referenced. Upgrade or apply it.
Timeline
- PublishedDisclosed publicly on CVE.org and NVD
- Last updatedMost recent change to the record
Why it ranks here
- Exploited in the wild: no, CISA does not list it.
- Exploit odds: 0.4% in the next 30 days (EPSS).
- Severity: 6.0 MEDIUM (CVSS).
- Fix: a patch or advisory is linked.
Details
- Published
- Last modified
- Exploit probability
- 0.4% · EPSS, next 30 days
- Weakness
- CWE-862 · Missing authorization
- Record status
- Analyzed
Affected
- GitHub Enterprise Server < 3.17.17
- GitHub Enterprise Server < 3.18.11
- GitHub Enterprise Server < 3.19.8
- GitHub Enterprise Server < 3.20.4
Attack profile CVSS 4.0 · 6.0
- Attack vector
- Network
- Complexity
- Low
- Attack requirements
- Present
- Privileges needed
- Low
- User interaction
- None
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Raw vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Is it in your code?
Hand this to your coding agent. It searches your project for the affected products and checks versions. Nothing leaves your machine.
Read https://cve-list.com/agent/cve/CVE-2026-9132.md and follow it. Check whether this project is affected by CVE-2026-9132. Read only. Don't change anything and don't upload my code. Tell me yes, no or not sure, with the file as proof.
References
- https://docs.github.com/en/[email protected]/admin/release-notes#3.17.17-features
- https://docs.github.com/en/[email protected]/admin/release-notes#3.18.11-features
- https://docs.github.com/en/[email protected]/admin/release-notes#3.19.8-features
- https://docs.github.com/en/[email protected]/admin/release-notes#3.20.4-features