CVE-2026-87689
What it is
The Metasploit Framework Web Service REST API (msf-ws) exposes the credential store through Msf::WebServices::CredentialServlet. Every mutating and read route in this servlet calls warden.authenticate! before processing a request, except the update_credential (PUT) and delete_credentials (DELETE) handlers for /api/v1/credentials, which omit the authentication call entirely. Because these handlers call directly into lib/msf/core/db_manager/cred.rb, which performs no authorization check of its own, any client able to reach the web service on its default 0.0.0.0:8080 listener can read, modify, or permanently delete every stored credential record — including passwords, hashes, and private keys stored for a shared team engagement — without presenting any authentication. All published versions of Metasploit Framework through 6.5.4 are affected. The issue is fixed in 6.5.5 by adding warden.authenticate! as the first statement in both handlers, matching the pattern used by every other route in the API.
At a glance
- Exploitability
- Can be exploited over the network without logging in. High risk of data exposure, data tampering, service disruption.
- Exploit odds
- 0.4% chance of exploitation in the next 30 days (EPSS).
- Fix
- A patch, advisory or fixed version is referenced. Upgrade or apply it.
Timeline
- ReservedThe CVE id was reserved by its CNA
- PublishedDisclosed publicly on CVE.org and NVD
- Last updatedMost recent change to the record
Why it ranks here
- Exploited in the wild: no, CISA does not list it.
- Exploit odds: 0.4% in the next 30 days (EPSS).
- Severity: 9.8 CRITICAL (CVSS).
- Fix: a patch or advisory is linked.
Details
- Published
- Last modified
- Exploit probability
- 0.4% · EPSS, next 30 days
- Weakness
- CWE-306 · Missing authentication
- Record status
- Awaiting Analysis
Attack profile CVSS 3.1 · 9.8
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Raw vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Is it in your code?
Hand this to your coding agent. It searches your project for the affected products and checks versions. Nothing leaves your machine.
Read https://cve-list.com/agent/cve/CVE-2026-87689.md and follow it. Check whether this project is affected by CVE-2026-87689. Read only. Don't change anything and don't upload my code. Tell me yes, no or not sure, with the file as proof.
Fix and advisories
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
References
- https://github.com/rapid7/metasploit-framework
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5
- https://github.com/rapid7/metasploit-framework/releases/tag/6.5.5