CVE-2026-76572
What it is
A vulnerability was detected in pkp pkp-lib up to 3.3.0-22/3.4.0-10/3.5.0-4. The affected element is the function _transformPHP of the file classes/xslt/XSLTransformer.php. The manipulation results in xml external entity reference. The attack can be executed remotely. Upgrading to version 3.3.0-23, 3.4.0-11 and 3.5.0-5 is sufficient to fix this issue. The patch is identified as 78c699370ea43ae2784e1c4ace7c947d207f2b47. Upgrading the affected component is advised.
At a glance
- Exploitability
- Can be exploited over the network with an admin-level account. Limited direct impact.
- Exploit odds
- 0.5% chance of exploitation in the next 30 days (EPSS).
- Fix
- A patch, advisory or fixed version is referenced. Upgrade or apply it.
Timeline
- PublishedDisclosed publicly on CVE.org and NVD
- Last updatedMost recent change to the record
Details
- Published
- Last modified
- Exploit probability
- 0.5% · EPSS, next 30 days
- Weakness
- CWE-610
- Record status
- Deferred
Attack profile CVSS 4.0 · 5.1
- Attack vector
- Network
- Complexity
- Low
- Attack requirements
- None
- Privileges needed
- High
- User interaction
- None
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Raw vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Fix and advisories
- https://github.com/pkp/pkp-lib/commit/78c699370ea43ae2784e1c4ace7c947d207f2b47
- https://github.com/pkp/pkp-lib/releases/tag/3_5_0-5
References
- https://github.com/pkp/pkp-lib/
- https://github.com/pkp/pkp-lib/commit/78c699370ea43ae2784e1c4ace7c947d207f2b47
- https://github.com/pkp/pkp-lib/issues/12977
- https://github.com/pkp/pkp-lib/releases/tag/3_5_0-5
- https://vuldb.com/cve/CVE-2026-76572
- https://vuldb.com/submit/878359
- https://vuldb.com/vuln/393037
- https://vuldb.com/vuln/393037/cti