CVE-20XX-?

CVE-2026-73263

9.9 CRITICAL 0.7% exploit odds Fix listed Injection Server

What it is

Prowler is a cloud security platform. Prior to 5.36.0, the Kubernetes provider connection test accepted kubeconfig_content containing a legacy gcp auth-provider with config.cmd-path and config.cmd-args because kubeconfig_contains_exec_auth in api/src/backend/api/v1/serializers.py checked only exec blocks, and POST /api/v1/providers/{id}/connection loaded it through config.load_kube_config_from_dict in prowler/providers/kubernetes/kubernetes_provider.py, causing kubernetes-python CommandTokenSource.token to run the attacker-supplied command through subprocess.Popen on the shared worker. This issue is fixed in version 5.36.0.

At a glance

Exploitability
Can be exploited over the network with a low-privilege account. High risk of data exposure, data tampering, service disruption.
Exploit odds
0.7% chance of exploitation in the next 30 days (EPSS).
Fix
A patch, advisory or fixed version is referenced. Upgrade or apply it.

Timeline

  1. PublishedDisclosed publicly on CVE.org and NVD
  2. Last updatedMost recent change to the record

Details

Published
Last modified
Exploit probability
0.7% · EPSS, next 30 days
Weakness
CWE-78 · OS command injection
Record status
Awaiting Analysis

Attack profile CVSS 3.1 · 9.9

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None
Scope
Changed
Confidentiality
High
Integrity
High
Availability
High
Raw vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Meme: I wake up, CVE-2026-73263
Download Square Reddit

Fix and advisories

References

NVD record · CVE.org record