CVE-2026-55573
What it is
e107 is a content management system (CMS). Prior to 2.3.7, install.php decodes the attacker-controlled previous_steps POST parameter and passes it to unserialize() at file scope and again in the e_install constructor without restricting allowed classes. The installer remains accessible after a normal installation, and a crafted object graph using the bundled GuzzleHttp\Psr7\PumpStream class can flow through paths.hash into site_path, where string coercion invokes an attacker-controlled callable. An unauthenticated attacker who can reach install.php can therefore execute arbitrary PHP functions with the web server process's privileges, leading to full server compromise. This issue is fixed in version 2.3.7.
At a glance
- Exploitability
- Can be exploited over the network without logging in. High risk of data exposure, data tampering, service disruption.
- Exploit odds
- 0.7% chance of exploitation in the next 30 days (EPSS).
- Fix
- A patch, advisory or fixed version is referenced. Upgrade or apply it.
Timeline
- ReservedThe CVE id was reserved by its CNA
- PublishedDisclosed publicly on CVE.org and NVD
- Last updatedMost recent change to the record
Why it ranks here
- Exploited in the wild: no, CISA does not list it.
- Exploit odds: 0.7% in the next 30 days (EPSS).
- Severity: 9.8 CRITICAL (CVSS).
- Fix: a patch or advisory is linked.
Details
- Published
- Last modified
- Exploit probability
- 0.7% · EPSS, next 30 days
- Weakness
- CWE-502 · Unsafe deserialization
- Record status
- Deferred
Attack profile CVSS 3.1 · 9.8
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Raw vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Is it in your code?
Hand this to your coding agent. It searches your project for the affected products and checks versions. Nothing leaves your machine.
Read https://cve-list.com/agent/cve/CVE-2026-55573.md and follow it. Check whether this project is affected by CVE-2026-55573. Read only. Don't change anything and don't upload my code. Tell me yes, no or not sure, with the file as proof.
Fix and advisories
- https://github.com/e107inc/e107/commit/5d6d649e8cf01854d6024d07997c2449fdd75f24
- https://github.com/e107inc/e107/commit/6c404295213952aedb9b3689be19dd4c7ba550b0
- https://github.com/e107inc/e107/releases/tag/v2.3.7
- https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8
- https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8
References
- https://github.com/e107inc/e107/commit/5d6d649e8cf01854d6024d07997c2449fdd75f24
- https://github.com/e107inc/e107/commit/6c404295213952aedb9b3689be19dd4c7ba550b0
- https://github.com/e107inc/e107/releases/tag/v2.3.7
- https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8
- https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8