CVE-20XX-?
agent?

CVE-2026-49872

5.3 MEDIUM 0.5% exploit odds Fix listed Auth & access Web app

What it is

Improper Authentication vulnerability in Apache APISIX. When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

At a glance

Exploitability
Can be exploited over the network with a low-privilege account. Limited direct impact.
Exploit odds
0.5% chance of exploitation in the next 30 days (EPSS).
Fix
A patch, advisory or fixed version is referenced. Upgrade or apply it.

Timeline

  1. PublishedDisclosed publicly on CVE.org and NVD
  2. Last updatedMost recent change to the record

Why it ranks here

Details

Published
Last modified
Exploit probability
0.5% · EPSS, next 30 days
Weakness
CWE-287 · Improper authentication
Record status
Analyzed

Affected

Attack profile CVSS 4.0 · 5.3

Attack vector
Network
Complexity
Low
Attack requirements
Present
Privileges needed
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
None
Raw vector

CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Is it in your code?

Hand this to your coding agent. It searches your project for the affected products and checks versions. Nothing leaves your machine.

Read https://cve-list.com/agent/cve/CVE-2026-49872.md and follow it. Check whether this project is affected by CVE-2026-49872. Read only. Don't change anything and don't upload my code. Tell me yes, no or not sure, with the file as proof.

· More options · Status badge

Meme: I wake up, CVE-2026-49872
Download Square Reddit

Fix and advisories

References

NVD record · CVE.org record