CVE-2026-33435
What it is
Weblate is a web based localization tool. In versions prior to 5.17, the project backup didn't filter Git and Mercurial configuration files which could lead to remote code execution under certain circumstances. This issue has been fixed in version 5.17. If developers are unable to update immediately, they can limit the scope of the vulnerability by restricting access to the project backup, as it is only accessible to users who can create projects.
At a glance
- Exploitability
- Can be exploited over the network with an admin-level account. High risk of data exposure, data tampering, service disruption.
- Exploit odds
- 0.7% chance of exploitation in the next 30 days (EPSS).
- Fix
- A patch, advisory or fixed version is referenced. Upgrade or apply it.
Timeline
- PublishedDisclosed publicly on CVE.org and NVD
- Last updatedMost recent change to the record
Details
- Published
- Last modified
- Exploit probability
- 0.7% · EPSS, next 30 days
- Weakness
- CWE-23
- Record status
- Analyzed
Affected
- Weblate < 5.17
Attack profile CVSS 3.1 · 8.0
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- None
- Scope
- Changed
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Raw vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
Fix and advisories
- https://github.com/WeblateOrg/weblate/pull/18549
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-558g-h753-6m33