CVE-20XX-?

CVE-2026-2839

5.3 MEDIUM 0.3% exploit odds Fix listed Auth & access Web app

What it is

The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.

At a glance

Exploitability
Can be exploited over the network without logging in. Limited direct impact.
Exploit odds
0.3% chance of exploitation in the next 30 days (EPSS).
Fix
A patch, advisory or fixed version is referenced. Upgrade or apply it.

Timeline

  1. PublishedDisclosed publicly on CVE.org and NVD
  2. Last updatedMost recent change to the record

Details

Published
Last modified
Exploit probability
0.3% · EPSS, next 30 days
Weakness
CWE-862 · Missing authorization
Record status
Deferred

Attack profile CVSS 3.1 · 5.3

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
None
Availability
None
Raw vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Meme: I wake up, CVE-2026-2839
Download Square Reddit

References

NVD record · CVE.org record