CVE-20XX-?

CVE-2026-24734

7.5 HIGH 0.6% exploit odds Fix listed Other Server

What it is

Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native:  from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.

At a glance

Exploitability
Can be exploited over the network without logging in. High risk of data tampering.
Exploit odds
0.6% chance of exploitation in the next 30 days (EPSS).
Fix
A patch, advisory or fixed version is referenced. Upgrade or apply it.

Timeline

  1. PublishedDisclosed publicly on CVE.org and NVD
  2. Last updatedMost recent change to the record

Details

Published
Last modified
Exploit probability
0.6% · EPSS, next 30 days
Weakness
CWE-20 · Improper input validation
Record status
Modified

Affected

Attack profile CVSS 3.1 · 7.5

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
High
Availability
None
Raw vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Meme: I wake up, CVE-2026-24734
Download Square Reddit

Fix and advisories

References

NVD record · CVE.org record