CVE-2026-19643
What it is
An out-of-bounds read issue in the Base64 decoder in Amazon aws-sdk-cpp before 1.11.862, on some platforms, might allow a remote authenticated user to crash an application that processes crafted Base64-encoded input. To remediate this issue, users should upgrade to version 1.11.862.
At a glance
- Exploitability
- Can be exploited over the network with a low-privilege account. High risk of service disruption.
- Exploit odds
- 0.6% chance of exploitation in the next 30 days (EPSS).
- Fix
- A patch, advisory or fixed version is referenced. Upgrade or apply it.
Timeline
- PublishedDisclosed publicly on CVE.org and NVD
- Last updatedMost recent change to the record
Details
- Published
- Last modified
- Exploit probability
- 0.6% · EPSS, next 30 days
- Weakness
- CWE-125 · Out-of-bounds read
- Record status
- Analyzed
Affected
- Amazon Aws Software Development Kit < 1.11.862
Attack profile CVSS 4.0 · 6.0
- Attack vector
- Network
- Complexity
- High
- Attack requirements
- Present
- Privileges needed
- Low
- User interaction
- None
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Raw vector
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Fix and advisories
- https://aws.amazon.com/security/security-bulletins/2026-080-aws/
- https://github.com/aws/aws-sdk-cpp/releases/tag/1.11.862
- https://github.com/aws/aws-sdk-cpp/security/advisories/GHSA-mxm9-xpf9-x66x