CVE-20XX-?
agent?

CVE-2025-69289

5.1 MEDIUM 0.2% exploit odds Fix listed Auth & access

What it is

Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.

At a glance

Exploitability
Can be exploited over the network with an admin-level account. Limited direct impact.
Exploit odds
0.2% chance of exploitation in the next 30 days (EPSS).
Fix
A patch, advisory or fixed version is referenced. Upgrade or apply it.

Timeline

  1. PublishedDisclosed publicly on CVE.org and NVD
  2. Last updatedMost recent change to the record

Why it ranks here

Details

Published
Last modified
Exploit probability
0.2% · EPSS, next 30 days
Weakness
CWE-863 · Incorrect authorization
Record status
Analyzed

Affected

Attack profile CVSS 4.0 · 5.1

Attack vector
Network
Complexity
Low
Attack requirements
None
Privileges needed
High
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
None
Raw vector

CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Is it in your code?

Hand this to your coding agent. It searches your project for the affected products and checks versions. Nothing leaves your machine.

Read https://cve-list.com/agent/cve/CVE-2025-69289.md and follow it. Check whether this project is affected by CVE-2025-69289. Read only. Don't change anything and don't upload my code. Tell me yes, no or not sure, with the file as proof.

· More options · Status badge

Meme: I wake up, CVE-2025-69289
Download Square Reddit

Fix and advisories

References

NVD record · CVE.org record