CVE-2025-65017
What it is
Decidim is a participatory democracy framework. In versions from 0.30.0 to before 0.30.4 and from 0.31.0.rc1 to before 0.31.0, the private data exports can lead to data leaks in case the UUID generation, causing collisions for the generated UUIDs. This issue has been patched in versions 0.30.4 and 0.31.0.
At a glance
- Exploitability
- Can be exploited over the network with a low-privilege account, but needs a user to act. High risk of data exposure.
- Exploit odds
- 0.3% chance of exploitation in the next 30 days (EPSS).
- Fix
- A patch, advisory or fixed version is referenced. Upgrade or apply it.
Timeline
- PublishedDisclosed publicly on CVE.org and NVD
- Last updatedMost recent change to the record
Details
- Published
- Last modified
- Exploit probability
- 0.3% · EPSS, next 30 days
- Weakness
- CWE-200 · Information exposure
- Record status
- Analyzed
Affected
- Decidim < 0.30.4
- Decidim 0.31.0
Attack profile CVSS 4.0 · 8.2
- Attack vector
- Network
- Complexity
- Low
- Attack requirements
- None
- Privileges needed
- Low
- User interaction
- Passive
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Raw vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Fix and advisories
- https://github.com/decidim/decidim/pull/13571
- https://github.com/decidim/decidim/releases/tag/v0.30.4
- https://github.com/decidim/decidim/releases/tag/v0.31.0
- https://github.com/decidim/decidim/security/advisories/GHSA-3cx6-j9j4-54mp