CVE-2025-58352
What it is
Weblate is a web based localization tool. Versions lower than 5.13.1 contain a vulnerability that causes long session expiry during the second factor verification. The long session expiry could be used to circumvent rate limiting of the second factor. This issue is fixed in version 5.13.1.
At a glance
- Exploitability
- Can be exploited over the network with a low-privilege account, but needs a user to act. Limited direct impact.
- Exploit odds
- 0.3% chance of exploitation in the next 30 days (EPSS).
- Fix
- A patch, advisory or fixed version is referenced. Upgrade or apply it.
Timeline
- PublishedDisclosed publicly on CVE.org and NVD
- Last updatedMost recent change to the record
Details
- Published
- Last modified
- Exploit probability
- 0.3% · EPSS, next 30 days
- Weakness
- CWE-613
- Record status
- Analyzed
Affected
- Weblate < 5.13.1
Attack profile CVSS 4.0 · 2.1
- Attack vector
- Network
- Complexity
- High
- Attack requirements
- Present
- Privileges needed
- Low
- User interaction
- Passive
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Raw vector
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Fix and advisories
- https://github.com/WeblateOrg/weblate/commit/0b46fe596231dd456283ead66699ae5516f23908
- https://github.com/WeblateOrg/weblate/pull/16002
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-377j-wj38-4728