CVE-2025-55296
What it is
librenms is a community-based GPL-licensed network monitoring system. A stored Cross-Site Scripting (XSS) vulnerability exists in LibreNMS (<= 25.6.0) in the Alert Template creation feature. This allows a user with the admin role to inject malicious JavaScript, which will be executed when the template is rendered, potentially compromising other admin accounts. This vulnerability is fixed in 25.8.0.
At a glance
- Exploitability
- Can be exploited over the network with an admin-level account. Limited direct impact.
- Exploit odds
- 17.0% chance of exploitation in the next 30 days (EPSS). Higher than most.
- Fix
- A patch, advisory or fixed version is referenced. Upgrade or apply it.
Timeline
- PublishedDisclosed publicly on CVE.org and NVD
- Last updatedMost recent change to the record
Details
- Published
- Last modified
- Exploit probability
- 17.0% · EPSS, next 30 days
- Weakness
- CWE-79 · Cross-site scripting
- Record status
- Analyzed
Affected
- Librenms < 25.8.0
Attack profile CVSS 3.1 · 5.5
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
- Scope
- Changed
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Raw vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
Fix and advisories
- https://github.com/librenms/librenms/commit/8ade3d827d317f5ac4b336617aafff865f825958
- https://github.com/librenms/librenms/security/advisories/GHSA-vxq6-8cwm-wj99