CVE-20XX-?
agent?

CVE-2012-10015

4.3 MEDIUM 0.4% exploit odds Fix listed

What it is

A vulnerability was found in BestWebSoft Twitter Plugin up to 2.14 on WordPress. It has been classified as problematic. Affected is the function twttr_settings_page of the file twitter.php of the component Settings Page. The manipulation leads to cross-site request forgery. It is possible to launch the attack remotely. Upgrading to version 2.15 is able to address this issue. The patch is identified as a6d4659cbb2cbf18ccb0fb43549d5113d74e0146. It is recommended to upgrade the affected component. VDB-230154 is the identifier assigned to this vulnerability.

At a glance

Exploitability
Can be exploited over the network without logging in, but needs a user to act. Limited direct impact.
Exploit odds
0.4% chance of exploitation in the next 30 days (EPSS).
Fix
A patch, advisory or fixed version is referenced. Upgrade or apply it.

Timeline

  1. PublishedDisclosed publicly on CVE.org and NVD
  2. Last updatedMost recent change to the record

Why it ranks here

Details

Published
Last modified
Exploit probability
0.4% · EPSS, next 30 days
Weakness
CWE-352 · Cross-site request forgery
Record status
Modified

Affected

Attack profile CVSS 3.1 · 4.3

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required
Scope
Unchanged
Confidentiality
None
Integrity
Low
Availability
None
Raw vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Is it in your code?

Hand this to your coding agent. It searches your project for the affected products and checks versions. Nothing leaves your machine.

Read https://cve-list.com/agent/cve/CVE-2012-10015.md and follow it. Check whether this project is affected by CVE-2012-10015. Read only. Don't change anything and don't upload my code. Tell me yes, no or not sure, with the file as proof.

· More options · Status badge

Meme: I wake up, CVE-2012-10015
Download Square Reddit

Fix and advisories

References

NVD record · CVE.org record